What’s Vulnerable › Vulnerabilities
CVE-2026-85102: Check Point Multiple Products Improper Certificate Validation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-22
- EPSS: 54.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-23
- Weakness: CWE-295
Description
Improper certificate trust validation during VPN negotiation in Check Point Quantum Security Gateway may allow an unauthenticated remote attacker to execute arbitrary code on the Gateway.
Affected products
- checkpoint Gaia Embedded: from r81.10.00 before r81.10.17; from r82.00.00 before r82.00.10; r81.10.17, r81.10.17-build_996004508, r81.10.17-build_996004620, r81.10.17-build_996004653, r81.10.17-build_996004721, r81.10.17-build_996004892 (+13) — fixed in r81.10.17, r82.00.10
- checkpoint Gaia Os: from r80 before r81.10; r81.10, r81.10-take_106, r81.10-take_107, r81.10-take_109, r81.10-take_110, r81.10-take_113 (+109) — fixed in r81.10
How to fix
Upgrade to a fixed version: checkpoint Gaia Embedded r81.10.17, r82.00.10; checkpoint Gaia Os r81.10. Check the vendor advisory for mitigations.
In the news
References
- https://support.checkpoint.com/results/sk/sk1000117
- https://blog.checkpoint.com/security/security-advisory-action-required-active-exploitation-of-cve-2026-85102-and-a-management-pre-authentication-vulnerability-cve-2026-93616/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-85102
Get alerted when CVE-2026-85102 or the next vulnerability affects your stack