What’s Vulnerable › Vulnerabilities
CVE-2026-85124: @fastify/http-proxy vulnerable to prefix escape via backslash dot-segments
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-22
Description
@fastify/http-proxy versions before 11.6.2 do not validate proxied HTTP request paths for backslash based dot-segments before forwarding them to the configured upstream. The plain HTTP request handler skips the destination validation that the WebSocket path performs, and the underlying reply-from library only rejects forward-slash traversal, so a request containing backslash dot-segments can escape the boundary set by the prefix and rewritePrefix options. An unauthenticated network attacker can use this to reach upstream paths that were meant to stay hidden behind the proxy, resulting in disclosure of internal endpoints. This is a path traversal issue (CWE-22). Users should upgrade to @fastify/http-proxy 11.6.2 or later.
Affected products
- @fastify/http-proxy: before 11.6.2 — fixed in 11.6.2
How to fix
Upgrade to a fixed version: @fastify/http-proxy 11.6.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-http-proxy/security/advisories/GHSA-qv33-689p-2xq5
Get alerted when CVE-2026-85124 or the next vulnerability affects your stack