What’s Vulnerable › Vulnerabilities
CVE-2026-85128: Choose User Role at Registration for WooCommerce < 1.3.3 - Unauthenticated Privilege Escalation via Registration Role Request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-269
Description
The Choose User Role at Registration WordPress plugin before 1.3.3 does not validate the role requested at registration against the roles an administrator chose to offer, allowing unauthenticated users to request any role, including administrator, and to be granted it once the request is approved. Exploitation requires the Choose User Role at Registration WordPress plugin before 1.3.3's role selection feature and public account registration to both be enabled.
Affected products
- Choose User Role at Registration: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: Choose User Role at Registration 1.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-85128 or the next vulnerability affects your stack