What’s Vulnerable › Vulnerabilities
CVE-2026-85167: n8n before 2.36.2 Query Injection via Elasticsearch Firestore Nodes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-10-29
- Weakness: CWE-943
Description
n8n before 2.35.4 and 2.36.x before 2.36.2 contain a query injection vulnerability in the Elasticsearch Document Get All and Google Cloud Firestore Document Query operations, which build their JSON query by interpolating expression values directly into the query string before parsing. A value containing quote and brace characters can close the intended field and introduce new query operators, turning an intended single-document lookup into a full-collection read.
Affected products
- n8n-io n8n: before 2.35.4; from 2.36.0 before 2.36.2 — fixed in 2.35.4, 2.36.2
- n8n-io n8n: from 2.36.0 before 2.36.2 — fixed in 2.36.2
How to fix
Upgrade to a fixed version: n8n-io n8n 2.35.4, 2.36.2; n8n-io n8n 2.36.2. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-wxwj-8wv6-vpw2
- https://www.vulncheck.com/advisories/n8n-before-2.36.2-query-injection-via-elasticsearch-firestore-nodes
Get alerted when CVE-2026-85167 or the next vulnerability affects your stack