What’s Vulnerable › Vulnerabilities
CVE-2026-85168: n8n before 1.123.73 Remote Code Execution via Git Node
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-10-29
- Weakness: CWE-78
Description
n8n versions before 1.123.73, 2.35.4, and 2.36.2 contain a remote code execution vulnerability in the Git node. The node reset a fixed list of command-bearing configuration keys before each operation, but that list did not cover the content-filter and merge-driver key families. A repository with local configuration setting one of those keys together with a matching attribute pattern causes git to execute the configured command during an ordinary Add, Commit, Checkout, or Pull operation. The command runs as the n8n process user.
Affected products
- n8n-io n8n: before 1.123.73; from 2.0.0 before 2.35.4; from 2.36.0 before 2.36.2 — fixed in 1.123.73, 2.35.4, 2.36.2
- n8n-io n8n: before 1.123.73 — fixed in 1.123.73
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.73, 2.35.4, 2.36.2; n8n-io n8n 1.123.73. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-mwp5-2m32-r54h
- https://www.vulncheck.com/advisories/n8n-before-1.123.73-remote-code-execution-via-git-node
Get alerted when CVE-2026-85168 or the next vulnerability affects your stack