What’s Vulnerable › Vulnerabilities

CVE-2026-85171: n8n before 1.123.73 Credential Exposure via Error Logging

Description

n8n before 1.123.73, 2.35.4, and 2.36.2 contains a credential exposure vulnerability in the Strapi, SeaTable, and Mailcheck nodes. These nodes send their decrypted credentials to the authentication endpoint via the raw legacy HTTP helper outside any error handling, causing the plaintext secret to be persisted in execution error data. Any authenticated user can read the plaintext secret from their own execution through the REST API, bypassing the blank-value redaction enforced by the credentials API.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.73, 2.35.4, 2.36.2; n8n-io n8n 1.123.73. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-85171 or the next vulnerability affects your stack