What’s Vulnerable › Vulnerabilities
CVE-2026-85228: Integer overflow in tensor buffer validation in Deep Java Library
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-10
- Weakness: CWE-190
Description
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload. To remediate this issue, users should upgrade to version 0.37.0 or above.
Affected products
- Amazon Deep Java Library: from 0.13.0 through 0.36.0
References
- https://aws.amazon.com/security/security-bulletins/2026-106-aws/
- https://github.com/deepjavalibrary/djl/releases/tag/v0.37.0
Get alerted when CVE-2026-85228 or the next vulnerability affects your stack