What’s Vulnerable › Vulnerabilities
CVE-2026-85241: SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-04
- Weakness: CWE-266
Description
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Affected products
- SpecterOps BloodHound: 9.0.0, 9.1.0, 9.2.2, 9.4.0, 9.5.0, 9.5.1
References
- https://github.com/SpecterOps/BloodHound/
- https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebb
- https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1
- https://vuldb.com/cve/CVE-2026-85241
- https://vuldb.com/submit/894488
- https://vuldb.com/vuln/398471
- https://vuldb.com/vuln/398471/cti
Get alerted when CVE-2026-85241 or the next vulnerability affects your stack