What’s Vulnerable › Vulnerabilities
CVE-2026-85437: MOOS-IvP through 24.8.1 Buffer Overflow in IvP Function String Decoders
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-10-14
- Weakness: CWE-787
Description
MOOS-IvP through 24.8.1 contains multiple buffer overflow vulnerabilities in IvP function string decoders that trust attacker-controlled length fields without validation. Attackers can craft malicious encoded strings with mismatched declared and actual field lengths to overflow heap and stack buffers, potentially achieving remote code execution through MOOS variables or alog files.
Affected products
- moos-ivp: before 24.8.1 — fixed in 24.8.1
How to fix
Upgrade to a fixed version: moos-ivp 24.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/moos-ivp/moos-ivp
- https://github.com/moos-ivp/moos-ivp/blob/1de9ae146cd63c209e8c3fd81611a4ed2472971b/ivp/src/lib_ivpbuild/FunctionEncoder.cpp#L310
- https://github.com/moos-ivp/moos-ivp/commit/81ca795fcfd62b42002d277f5a2390f4c8ab8c7f
- https://github.com/moos-ivp/moos-ivp/pull/125
- https://www.vulncheck.com/advisories/moos-ivp-through-24.8.1-buffer-overflow-in-ivp-function-string-decoders
Get alerted when CVE-2026-85437 or the next vulnerability affects your stack