What’s Vulnerable › Vulnerabilities
CVE-2026-85505
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-09
- Weakness: CWE-125
Description
ipmi-oem in FreeIPMI before 1.6.19 has a stack-based buffer over-read in ipmi_oem_fujitsu_get_sel_entry_long_text in ipmi-oem/ipmi-oem-fujitsu.c when a BMC provides a short response, a different vulnerability than CVE-2026-50031 (which has different affected versions).
Affected products
- FreeIPMI: before 1.6.19 — fixed in 1.6.19
How to fix
Upgrade to a fixed version: FreeIPMI 1.6.19. Check the vendor advisory for mitigations.
References
- https://ftp.gnu.org/gnu/freeipmi/freeipmi-1.6.19.tar.gz
- https://www.gnu.org/software/freeipmi/
- https://www.openwall.com/lists/oss-security/2026/08/28/5
Get alerted when CVE-2026-85505 or the next vulnerability affects your stack