What’s Vulnerable › Vulnerabilities
CVE-2026-85532: Apache WSS4J: Insufficient Validation of Derived-Key Parameters
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-02
- Weakness: CWE-20
Description
Apache WSS4J accepted attacker-controlled derived-key lengths and offsets without adequate bounds. This could permit cryptographically weak keys or excessive CPU and memory consumption when processing crafted WS-Security messages. The fixes enforce a minimum key length of 16 bytes, a maximum length of 512 bytes, and a maximum offset of 4096 bytes. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected products
- Apache Software Foundation Apache WSS4J: before 2.4.4; from 3.0.0 before 3.0.6; from 4.0.0 before 4.0.2 — fixed in 2.4.4, 3.0.6, 4.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache WSS4J 2.4.4, 3.0.6, 4.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/7jllcpbf4nbzhdp2vchz5yplnl5w6vd6
- http://www.openwall.com/lists/oss-security/2026/09/30/8
Get alerted when CVE-2026-85532 or the next vulnerability affects your stack