What’s Vulnerable › Vulnerabilities
CVE-2026-85589: phpMyFAQ before 4.2.0-alpha.2 Missing Authorization via Dashboard API
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-862
Description
phpMyFAQ before 4.2.0-alpha.2 contains a missing authorization vulnerability in the admin dashboard API endpoints searches and content-health that enforce only authentication without permission checks. Any authenticated user can access these endpoints to read site-wide search statistics and content-health counters regardless of their privilege level.
Affected products
- thorsten phpMyFAQ: before 4.2.0-alpha.2 — fixed in 4.2.0-alpha.2
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.2.0-alpha.2. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-gpwm-82cg-4wfw
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.2.0-alpha.2-missing-authorization-via-dashboard-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-gpwm-82cg-4wfw
Get alerted when CVE-2026-85589 or the next vulnerability affects your stack