What’s Vulnerable › Vulnerabilities
CVE-2026-85591: phpMyFAQ before 4.1.8 Authentication Bypass via Unverified Password Change
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-10
- Weakness: CWE-620
Description
phpMyFAQ versions before 4.1.8 contain an authentication bypass vulnerability in the user control panel API endpoint that allows authenticated attackers to change account passwords without verifying the current password. Attackers with session access can submit a PUT request to the user data update endpoint with only a CSRF token to silently change any user's password, including administrators, causing irreversible account takeover and victim lockout.
Affected products
- thorsten phpMyFAQ: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6r2c-694w-24qv
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.8-authentication-bypass-via-unverified-password-change
Get alerted when CVE-2026-85591 or the next vulnerability affects your stack