What’s Vulnerable › Vulnerabilities
CVE-2026-85592: phpMyFAQ before 4.1.8 Authorization Bypass via question/create
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-863
Description
phpMyFAQ before 4.1.8 contains an authorization bypass vulnerability in the question creation endpoint where the isAddingQuestionsAllowed() method grants access to all callers when main.enableAskQuestions is enabled, ignoring the records.allowQuestionsForGuests setting. Unauthenticated attackers can submit questions via the question/create API endpoint to bypass guest submission restrictions and inject spam into the admin moderation queue.
Affected products
- thorsten phpMyFAQ: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-546h-9ghq-x49g
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.8-authorization-bypass-via-question-create
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-546h-9ghq-x49g
Get alerted when CVE-2026-85592 or the next vulnerability affects your stack