What’s Vulnerable › Vulnerabilities
CVE-2026-85593: phpMyFAQ before 4.1.8 Stored XSS via html_entity_decode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-14
- Weakness: CWE-79
Description
phpMyFAQ versions before 4.1.8 contain a stored cross-site scripting vulnerability in FaqHelper::convertOldInternalLinks() that calls html_entity_decode() on sanitized FAQ content, reversing entity-encoding protection. Authenticated users with FAQ editing privileges can inject JavaScript payloads that execute in the browsers of all users viewing the affected FAQ pages.
Affected products
- thorsten phpMyFAQ: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-x6qj-5jhf-xgpm
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.8-stored-xss-via-html-entity-decode
Get alerted when CVE-2026-85593 or the next vulnerability affects your stack