What’s Vulnerable › Vulnerabilities
CVE-2026-85599: Grav Shortcode Core before 6.2.5 Stored XSS via unescaped parameters
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-79
Description
Grav Shortcode Core before 6.2.5 contains stored cross-site scripting vulnerabilities in the [lorem] tag parameter and [details] summary parameter that are written to rendered pages without escaping. Attackers with page-edit access can inject arbitrary HTML and JavaScript that executes in the browsers of all page visitors, including administrators.
Affected products
- getgrav grav-plugin-shortcode-core: before 6.2.5 — fixed in 6.2.5
How to fix
Upgrade to a fixed version: getgrav grav-plugin-shortcode-core 6.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-hvm8-wx3f-j774
- https://www.vulncheck.com/advisories/grav-shortcode-core-before-6.2.5-stored-xss-via-unescaped-parameters
- https://github.com/getgrav/grav/security/advisories/GHSA-hvm8-wx3f-j774
Get alerted when CVE-2026-85599 or the next vulnerability affects your stack