What’s Vulnerable › Vulnerabilities
CVE-2026-85600: Grav Admin before 2.0.21 Stored XSS via username
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-79
Description
Grav Admin (getgrav/grav-plugin-admin2) versions <= 2.0.19 contain a stored cross-site scripting vulnerability in the tHtml() function (src/lib/stores/i18n.svelte.ts), which substitutes untrusted parameters such as usernames into translation templates before parsing the result as markdown. Grav's server-side username validation (DataUser::isValidUsername) blocks filesystem-dangerous characters but not <, >, ", or ', allowing an attacker to register a username containing an HTML payload. When an administrator views a UI surface that renders the username through tHtml()—such as the two-factor force-disable confirmation prompt or the 'page is locked' editor notice—the payload executes in their authenticated session. Fixed in 2.0.21.
Affected products
- getgrav grav-plugin-admin2: through 2.0.19
References
- https://github.com/getgrav/grav/security/advisories/GHSA-96xm-c5hr-59rx
- https://www.vulncheck.com/advisories/grav-admin-before-2.0.21-stored-xss-via-username
- https://github.com/getgrav/grav/security/advisories/GHSA-96xm-c5hr-59rx
Get alerted when CVE-2026-85600 or the next vulnerability affects your stack