What’s Vulnerable › Vulnerabilities
CVE-2026-85601: Grav Admin before 2.0.20 Cross-Site Scripting via marked.js
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-10
- Weakness: CWE-79
Description
Grav Admin before 2.0.20 fails to sanitize output from marked.parse() before injecting it into the DOM via Svelte's {@html} directive in MarkdownEditor and MarkdownModal components. Attackers can inject javascript: URI schemes in plugin or theme changelogs to execute arbitrary code in authenticated admin sessions without requiring site access.
Affected products
- getgrav grav: before 2.0.20 — fixed in 2.0.20
How to fix
Upgrade to a fixed version: getgrav grav 2.0.20. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-752r-88j4-vxm3
- https://www.vulncheck.com/advisories/grav-admin-before-2.0.20-cross-site-scripting-via-marked-js
Get alerted when CVE-2026-85601 or the next vulnerability affects your stack