What’s Vulnerable › Vulnerabilities
CVE-2026-85609: Openpanel before 2.3.0 SSRF via Site Checker Endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-10-27
- Weakness: CWE-918
Description
Openpanel before 2.3.0 contains an unauthenticated full-read server-side request forgery (SSRF) vulnerability in the GET /tools/site-checker endpoint (apps/api/src/controllers/tools.controller.ts). The endpoint passes a user-supplied url query parameter to fetchWithRedirects() and performs server-side HTTP requests to arbitrary URLs without any SSRF/IP validation. An unauthenticated remote attacker can access cloud instance metadata endpoints, probe internal services, scan internal network ports, and read returned content (status code, page size, timing, and parsed HTML metadata), and leak internal IP addresses (via getIPInfo() to a third party).
Affected products
- Openpanel-dev openpanel: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Openpanel-dev openpanel 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-r3jv-rmrg-j395
- https://www.vulncheck.com/advisories/openpanel-before-2.3.0-ssrf-via-site-checker-endpoint
Get alerted when CVE-2026-85609 or the next vulnerability affects your stack