What’s Vulnerable › Vulnerabilities
CVE-2026-85610: OpenPanel before 2.3.0 Remote Code Execution via chart formulas
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-10-27
- Weakness: CWE-94
Description
OpenPanel before 2.3.0 fails to properly validate chart formula expressions, allowing authenticated project members with read access to execute arbitrary code by recovering the native JavaScript Function constructor through mathjs matrix objects. Attackers can use the recovered constructor to load Node.js built-ins and execute operating system commands with the privileges of the API process, bypassing organization authorization boundaries.
Affected products
- Openpanel-dev openpanel: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Openpanel-dev openpanel 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-7476-c5cc-8999
- https://www.vulncheck.com/advisories/openpanel-before-2.3.0-remote-code-execution-via-chart-formulas
Get alerted when CVE-2026-85610 or the next vulnerability affects your stack