What’s Vulnerable › Vulnerabilities
CVE-2026-85612: OpenPanel before 2.3.0 SSRF via favicon and og endpoints
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-10-27
- Weakness: CWE-918
Description
OpenPanel before 2.3.0 contains an unauthenticated server-side request forgery vulnerability in the /misc/favicon and /misc/og endpoints that accept an attacker-supplied url parameter with insufficient validation. Attackers can force the API to fetch arbitrary internal hosts and cloud metadata endpoints, with small responses returned verbatim enabling credential theft and internal service enumeration.
Affected products
- Openpanel-dev openpanel: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Openpanel-dev openpanel 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-2hff-m67f-2w2w
- https://www.vulncheck.com/advisories/openpanel-before-2.3.0-ssrf-via-favicon-and-og-endpoints
Get alerted when CVE-2026-85612 or the next vulnerability affects your stack