What’s Vulnerable › Vulnerabilities
CVE-2026-85614: OpenPanel API before 2.3.0 Unauthenticated SSRF via site-checker
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-10-27
- Weakness: CWE-918
Description
OpenPanel before 2.3.0 contains an unauthenticated server-side request forgery vulnerability in the GET /tools/site-checker endpoint that accepts a fully client-controlled URL parameter with no private IP filtering or DNS-rebinding protection. Attackers can make the OpenPanel server issue requests to internal services, localhost, and cloud metadata endpoints, reading internal HTTP response titles, headers, status codes, and SSL certificate information.
Affected products
- Openpanel-dev openpanel: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Openpanel-dev openpanel 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-gqcr-xgfj-pq29
- https://www.vulncheck.com/advisories/openpanel-api-before-2.3.0-unauthenticated-ssrf-via-site-checker
Get alerted when CVE-2026-85614 or the next vulnerability affects your stack