What’s Vulnerable › Vulnerabilities
CVE-2026-85678: AI Builder 2.4.1 - 2.7.7 - Contributor+ Stored XSS via Post JavaScript
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-11
- Weakness: CWE-79
Description
The AI Builder WordPress plugin before 2.7.8 does not sanitise custom JavaScript saved against a post before echoing it inside a script tag on the front end, allowing users with contributor level access and above to store arbitrary JavaScript that will execute in the browser of anyone who views the post, including the editor or administrator who reviews it.
Affected products
- AI Builder: from 2.4.1 before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: AI Builder 2.7.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-85678 or the next vulnerability affects your stack