What’s Vulnerable › Vulnerabilities
CVE-2026-85787: An incomplete list of disallowed inputs in the SQL validation component of Amazon awslabs postgres-mcp-server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-184
Description
An incomplete list of disallowed inputs in the SQL validation component in Amazon awslabs postgres-mcp-server before version 1.1.7 might allow an unauthenticated actor to modify data beyond the read-only scope by placing crafted SQL into the content that is submitted when an authenticated user interacts with the MCP server. To remediate this issue, users should upgrade to version 1.1.7 or above.
Affected products
- Amazon postgres-mcp-server: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Amazon postgres-mcp-server 1.1.7. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-101-aws/
- https://pypi.org/project/awslabs.postgres-mcp-server/1.1.7/
Get alerted when CVE-2026-85787 or the next vulnerability affects your stack