What’s Vulnerable › Vulnerabilities
CVE-2026-85979: Command Injection in Puppet Enterprise
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-18
- Weakness: CWE-20
Description
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.
Affected products
- Perforce Software Puppet Enterprise: from 2023.8.0 through 2023.8.10; from 2025.0.0 through 2025.11.2
References
Get alerted when CVE-2026-85979 or the next vulnerability affects your stack