What’s Vulnerable › Vulnerabilities
CVE-2026-86039: libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-24
- Weakness: CWE-290
Description
libp2p is a JavaScript implementation of the libp2p networking stack. From 8.0.0 until 12.0.24, @libp2p/peer-store in packages/peer-store/src/index.ts uses consumePeerRecord to verify a RecordEnvelope signature but does not require PeerRecord.peerId in the signed payload to equal the signer peer ID derived by RecordEnvelope.openAndCertify. The expectedPeer option checks only the envelope signer, and the gossipsub Peer Exchange path can provide the attacker's own peer ID as expectedPeer. An attacker can therefore sign a record with the attacker's key, place a victim peer ID and attacker-controlled multiaddrs in the payload, and have certified addresses stored for the victim. The poisoned addresses can cause address-book corruption, dial redirection or failure, routing manipulation, and reachability disruption, although the connection upgrade still verifies remote peer identity and prevents a complete identity takeover. The issue is fixed in version 12.0.24.
Affected products
- libp2p js-libp2p: from 8.0.0, < 12.0.24
References
- https://github.com/libp2p/js-libp2p/commit/3bf5d395cbca1488eea6e87cd771e4613b661c30
- https://github.com/libp2p/js-libp2p/pull/3570
- https://github.com/libp2p/js-libp2p/releases/tag/peer-store-v12.0.24
- https://github.com/libp2p/js-libp2p/security/advisories/GHSA-vrf4-mx87-p53w
- https://github.com/libp2p/js-libp2p/security/advisories/GHSA-vrf4-mx87-p53w
Get alerted when CVE-2026-86039 or the next vulnerability affects your stack