What’s Vulnerable › Vulnerabilities
CVE-2026-86114: Arcane before 2.0.0 Missing Administrator Authorization on the Compose Template Mutation Endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-23
- Weakness: CWE-862
Description
Arcane versions before 2.0.0 fail to properly restrict template operations, allowing default user role accounts to create, modify, and delete compose templates including instance-wide defaults. Attackers can inject malicious container configurations with privileged settings or host path mounts that execute with administrative privileges when deployed by administrators.
Affected products
- getarcaneapp arcane: from 1.19.1 before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: getarcaneapp arcane 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/geo-chen/oss/blob/main/arcane.md
- https://github.com/getarcaneapp/arcane
- https://github.com/getarcaneapp/arcane/blob/v1.19.5/backend/api/handlers/templates.go
- https://github.com/getarcaneapp/arcane/commit/1500646aa91f
- https://github.com/getarcaneapp/arcane/releases/tag/v2.0.0
- https://www.vulncheck.com/advisories/arcane-before-2.0.0-missing-administrator-authorization-on-the-compose-template-mutation-endpoints
Get alerted when CVE-2026-86114 or the next vulnerability affects your stack