What’s Vulnerable › Vulnerabilities
CVE-2026-86138
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-15
- Weakness: CWE-190
Description
In libxml2 before 2.15.4, xmlDictAddQString in dict.c has an integer overflow and resultant heap-based buffer overflow.
Affected products
- xmlsoft libxml2: before 2.15.4 — fixed in 2.15.4
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/GNOME/libxml2/commit/a4cba4b5b5a8c42e155ed42d2d2a44955465a2e4
- https://github.com/GNOME/libxml2/compare/v2.15.3...v2.15.4
Get alerted when CVE-2026-86138 or the next vulnerability affects your stack