What’s Vulnerable › Vulnerabilities
CVE-2026-86142
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-15
- Weakness: CWE-122
Description
In libxml2 before 2.15.4, there is a heap-based buffer overflow in xmlXPtrEvalXPtrPart because of xmlXPtrEval xpointer length saturation.
Affected products
- xmlsoft libxml2: before 2.15.4 — fixed in 2.15.4
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/GNOME/libxml2/commit/6b3a736c0edc74ceec3d82f5252499d7911b3a58
- https://github.com/GNOME/libxml2/compare/v2.15.3...v2.15.4
- https://gitlab.gnome.org/GNOME/libxml2/-/work_items/1113
Get alerted when CVE-2026-86142 or the next vulnerability affects your stack