What’s Vulnerable › Vulnerabilities
CVE-2026-86143
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-05 · updated 2026-09-15
- Weakness: CWE-192
Description
In xmlIO in libxml2 before 2.15.4, an inconsistency in xmlOutputWriteCallback and xmlBufUse causes negative lengths to reach write callbacks, aka a lack of a check for integer overflow before calling writecallback. This has security relevance for many types of uses of that length value within a callback.
Affected products
- xmlsoft libxml2: before 2.15.4 — fixed in 2.15.4
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/GNOME/libxml2/commit/90f293ba74d28b1d570920382e707586f68ebf35
- https://github.com/GNOME/libxml2/compare/v2.15.3...v2.15.4
- https://gitlab.gnome.org/GNOME/libxml2/-/work_items/1111
Get alerted when CVE-2026-86143 or the next vulnerability affects your stack