What’s Vulnerable › Vulnerabilities
CVE-2026-86169: Axolotl before 0.19.0 Remote Code Execution via Multipack Patching
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-23
- Weakness: CWE-829
Description
Axolotl before 0.19.0 contains a remote code execution vulnerability in the multipack patch path where trust_remote_code defaults to None instead of False, causing the security guard to be bypassed. Attackers can execute arbitrary Python code by crafting a malicious Hugging Face model repository selected as base_model, which is loaded with hardcoded trust_remote_code=True during AutoModelForCausalLM.from_pretrained.
Affected products
- axolotl-ai-cloud axolotl: before 0.19.0 — fixed in 0.19.0
How to fix
Upgrade to a fixed version: axolotl-ai-cloud axolotl 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/axolotl-ai-cloud/axolotl
- https://github.com/axolotl-ai-cloud/axolotl/blob/v0.18.0/src/axolotl/loaders/patch_manager.py#L794-L806
- https://github.com/axolotl-ai-cloud/axolotl/blob/v0.18.0/src/axolotl/monkeypatch/multipack.py#L86-L96
- https://github.com/axolotl-ai-cloud/axolotl/commit/b62d60b101eea7f32532ee3c0b17c2f2430a9262
- https://github.com/axolotl-ai-cloud/axolotl/pull/3858
- https://github.com/axolotl-ai-cloud/axolotl/releases/tag/v0.19.0
- https://www.vulncheck.com/advisories/axolotl-through-0.18.0-remote-code-execution-via-multipack-patching
Get alerted when CVE-2026-86169 or the next vulnerability affects your stack