What’s Vulnerable › Vulnerabilities
CVE-2026-86193: Grav API Plugin Authentication Bypass via Group-Inherited Super
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-863
Description
grav-plugin-api before 1.0.20 fails to validate group-inherited super permissions in user-management guards, allowing non-super user managers to modify super-admin accounts. Attackers with api.access and api.users.write can patch password fields on group-super accounts to gain full administrative control.
Affected products
- getgrav grav-plugin-api: before 1.0.20 — fixed in 1.0.20
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.20. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-vv8m-jqpm-38x4
- https://www.vulncheck.com/advisories/grav-api-plugin-authentication-bypass-via-group-inherited-super
- https://github.com/getgrav/grav/security/advisories/GHSA-vv8m-jqpm-38x4
Get alerted when CVE-2026-86193 or the next vulnerability affects your stack