What’s Vulnerable › Vulnerabilities
CVE-2026-86194: Grav Form Plugin before 9.1.22 Cross-Page Form Execution
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-18
- Weakness: CWE-862
Description
Grav Form Plugin before 9.1.22 fails to verify page authorization when resolving forms by name across pages, allowing anonymous visitors to execute form actions defined on login-restricted or unpublished pages. Attackers can POST to any public page with a restricted form's name to trigger save, upload, email, or call actions without authentication.
Affected products
- getgrav grav-plugin-form: before 9.1.22 — fixed in 9.1.22
How to fix
Upgrade to a fixed version: getgrav grav-plugin-form 9.1.22. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-33m4-m988-5fvh
- https://www.vulncheck.com/advisories/grav-form-plugin-before-9.1.22-cross-page-form-execution
Get alerted when CVE-2026-86194 or the next vulnerability affects your stack