What’s Vulnerable › Vulnerabilities
CVE-2026-86196: Grav API Plugin before 1.0.20 Authentication Bypass via Host Header
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-290
Description
Grav API plugin versions before 1.0.20 build password reset links from the untrusted Host header in the forgot-password endpoint, allowing unauthenticated attackers to redirect reset tokens to attacker-controlled domains. Attackers can send password reset requests for any account with a malicious Host header, intercept the reset token from victim emails, and complete account takeover including super-admin accounts.
Affected products
- getgrav grav-plugin-api: before 1.0.20 — fixed in 1.0.20
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.20. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-262p-56vv-7v5r
- https://www.vulncheck.com/advisories/grav-api-plugin-before-1.0.20-authentication-bypass-via-host-header
Get alerted when CVE-2026-86196 or the next vulnerability affects your stack