What’s Vulnerable › Vulnerabilities
CVE-2026-86199: PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-09
- Weakness: CWE-184
Description
PocketMine-MP versions before 5.43.1 fail to properly validate the Certificate field during offline login authentication. Unauthenticated players can trigger an uninitialized property access error that crashes the server.
Affected products
- pmmp PocketMine-MP: before 5.43.1 — fixed in 5.43.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 5.43.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/8c75a1d739e8e190d3cc2338b25cebcc9c052b1b
- https://github.com/pmmp/PocketMine-MP/commit/e4aaef4ee0f769b52dc0347a1d6da403b9691115
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g2fj-p69p-9chp
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.43.1-denial-of-service-via-unauthenticated-login
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g2fj-p69p-9chp
Get alerted when CVE-2026-86199 or the next vulnerability affects your stack