What’s Vulnerable › Vulnerabilities
CVE-2026-8620: IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by multiple vulnerabilities when using when using Web Server Plug-ins
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-23
- Weakness: CWE-444
Description
IBM Web Server Plug-ins for WebSphere Application Server and WebSphere Liberty 8.5, 9.0 IBM WebSphere Application Server and WebSphere Application Server Liberty are vulnerable to HTTP request smuggling in the Web Server Plug-ins through a specially crafted request.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.30; from 9.0.0.0 before 9.0.5.28 — fixed in 8.5.5.30, 9.0.5.28
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.30, 9.0.5.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8620 or the next vulnerability affects your stack