What’s Vulnerable › Vulnerabilities
CVE-2026-86201: PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-08
- Weakness: CWE-400
Description
PocketMine-MP before 5.41.1 contains a denial of service vulnerability in LoginPacket processing where large or complex structures in unknown clientData JWT properties cause excessive logging without sanitization. Attackers can send crafted LoginPackets with deeply nested or massive object structures to trigger out-of-memory conditions and crash the server.
Affected products
- pmmp PocketMine-MP: before 5.41.1 — fixed in 5.41.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 5.41.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/87d1c0cea09d972fd4c2fafb84dac2ecab7649f0
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-h6rj-3m53-887h
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.41.1-logdos-via-loginpacket-clientdata
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-h6rj-3m53-887h
Get alerted when CVE-2026-86201 or the next vulnerability affects your stack