What’s Vulnerable › Vulnerabilities
CVE-2026-86204: PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-08
- Weakness: CWE-400
Description
PocketMine-MP versions before 5.39.2 fail to limit JSON payload size in ModalFormResponsePacket handling, allowing authenticated players to cause denial of service. Attackers can send modal form response packets with massive JSON arrays to exhaust server memory and CPU resources, rendering the server unresponsive.
Affected products
- pmmp PocketMine-MP: before 5.39.2 — fixed in 5.39.2
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 5.39.2. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-788v-5pfp-93ff
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.39.2-denial-of-service-via-modalformresponsepacket
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-788v-5pfp-93ff
Get alerted when CVE-2026-86204 or the next vulnerability affects your stack