What’s Vulnerable › Vulnerabilities

CVE-2026-86243: Apache Tomcat Native: DoS via TLS handshake

Description

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Tomcat Native 1.3.9, 2.0.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-86243 or the next vulnerability affects your stack