What’s Vulnerable › Vulnerabilities
CVE-2026-86247: Apache Tomcat Native: Client certificate requirements can be down-graded
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-10-06
- Weakness: CWE-366
Description
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache Tomcat Native: from 1.3.0 before 1.3.9; from 2.0.0 before 2.0.16 — fixed in 1.3.9, 2.0.16
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tomcat Native 1.3.9, 2.0.16. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/obsson6zhvfg0wsp2bx602l61ltj87r1
- http://www.openwall.com/lists/oss-security/2026/09/23/33
Get alerted when CVE-2026-86247 or the next vulnerability affects your stack