What’s Vulnerable › Vulnerabilities
CVE-2026-86255: wger before 2.5 Uncontrolled Resource Consumption via date_sequence
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-09-18
- Weakness: CWE-400
Description
wger before 2.5 fails to validate the maximum duration of routine date ranges, allowing authenticated users to create routines spanning arbitrarily long periods. Attackers can trigger the date_sequence computation via routine detail endpoints, forcing the server to iterate thousands of times per request and exhaust worker threads, denying service to legitimate users.
Affected products
- wger-project wger: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: wger-project wger 2.5. Check the vendor advisory for mitigations.
References
- https://github.com/wger-project/wger/security/advisories/GHSA-v25j-wqcw-fvhj
- https://www.vulncheck.com/advisories/wger-before-2.5-uncontrolled-resource-consumption-via-date-sequence
Get alerted when CVE-2026-86255 or the next vulnerability affects your stack