What’s Vulnerable › Vulnerabilities
CVE-2026-86289: Ollama GGUF Decoder gguf.go readGGUFV1String integer overflow
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-09-11
- Weakness: CWE-189
Description
A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.
Affected products
- Ollama: 0.31.0, 0.31.1
References
- https://github.com/ollama/ollama/
- https://github.com/ollama/ollama/commit/67b6a1c2d45321e0cb3c04a18073f9818de7724b
- https://github.com/ollama/ollama/issues/17033
- https://github.com/ollama/ollama/pull/17062
- https://github.com/ollama/ollama/releases/tag/v0.31.2-rc1
- https://vuldb.com/cve/CVE-2026-86289
- https://vuldb.com/submit/906136
- https://vuldb.com/vuln/399448
- https://vuldb.com/vuln/399448/cti
Get alerted when CVE-2026-86289 or the next vulnerability affects your stack