What’s Vulnerable › Vulnerabilities
CVE-2026-8632: HP Linux Imaging and Printing Software – Potential Escalation of Privilege and Arbitrary Code Execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-20 · updated 2026-08-04
- Weakness: CWE-77
Description
A potential security vulnerability has been identified in the HP Linux Imaging and Printing Software. This potential vulnerability may allow escalation of privileges and/or arbitrary code execution via operating system command injection.
Affected products
- HP Inc. HP Linux Imaging and Printing Software (HPLIP): before 3.26.4 — fixed in 3.26.4
How to fix
Upgrade to a fixed version: HP Inc. HP Linux Imaging and Printing Software (HPLIP) 3.26.4. Check the vendor advisory for mitigations.
References
- https://support.hp.com/us-en/document/ish_14942099-14942126-16/hpsbpi04118
- https://access.redhat.com/errata/RHSA-2026:26228
- https://access.redhat.com/errata/RHSA-2026:26297
- https://access.redhat.com/errata/RHSA-2026:26335
- https://access.redhat.com/errata/RHSA-2026:48171
- https://access.redhat.com/errata/RHSA-2026:48586
- https://access.redhat.com/errata/RHSA-2026:48603
- https://access.redhat.com/errata/RHSA-2026:48606
- https://access.redhat.com/errata/RHSA-2026:48959
- https://access.redhat.com/errata/RHSA-2026:48960
- https://access.redhat.com/errata/RHSA-2026:48961
- https://access.redhat.com/security/cve/CVE-2026-8632
Get alerted when CVE-2026-8632 or the next vulnerability affects your stack