What’s Vulnerable › Vulnerabilities
CVE-2026-8635: Arbitrary Code Execution in Python Interpreter Component
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-94
Description
IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated users to escalate privileges to superuser by directly manipulating the database, execute arbitrary system commands, and achieve full system compromise with Langflow service permissions.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8635 or the next vulnerability affects your stack