What’s Vulnerable › Vulnerabilities
CVE-2026-86420: ImageMagick before 7.1.2-30 Denial of Service Memory Budget
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-29
- Weakness: CWE-400
Description
ImageMagick before 7.1.2-30 and 6.9.13-55 fails to properly lower the memory budget when an operation inside OpenPixelCache fails. Repeated triggering of such failures can exhaust the process memory budget and result in a denial of service.
Affected products
- ImageMagick: before 6.9.13-55; from 7.0.0-0 before 7.1.2-30 — fixed in 6.9.13-55, 7.1.2-30
- ImageMagick: from 7.0.0 before 7.1.2-30 — fixed in 7.1.2-30
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-55, 7.1.2-30; ImageMagick 7.1.2-30. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-4mwf-mggw-29vp
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-30-denial-of-service-memory-budget
Get alerted when CVE-2026-86420 or the next vulnerability affects your stack