What’s Vulnerable › Vulnerabilities
CVE-2026-86425: ImageMagick before 7.1.2-30 Heap-use-after-free via Layer
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-29
- Weakness: CWE-416
Description
ImageMagick before 7.1.2-30 and 6.9.x before 6.9.13-55 contains a heap-use-after-free vulnerability in the Layer method of PerlMagick. An attacker who supplies a crafted list of images can trigger memory access after deallocation, resulting in a crash (denial of service).
Affected products
- ImageMagick: before 6.9.13-55; from 7.0.0-0 before 7.1.2-30 — fixed in 6.9.13-55, 7.1.2-30
- ImageMagick: from 7.0.0 before 7.1.2-30 — fixed in 7.1.2-30
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-55, 7.1.2-30; ImageMagick 7.1.2-30. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-chf5-8rv9-gjqr
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-30-heap-use-after-free-via-layer
Get alerted when CVE-2026-86425 or the next vulnerability affects your stack