What’s Vulnerable › Vulnerabilities
CVE-2026-86426: LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-07 · updated 2026-09-18
- Weakness: CWE-287
Description
LibreNMS before 26.8.0 contains an authentication bypass vulnerability in the REST API that allows unauthenticated attackers to access protected endpoints by sending numeric values instead of string tokens. Attackers can exploit MySQL type coercion by sending small integers like 0 through 9 to match token hashes, gaining access to API functionality including device credentials and administrative features that enable remote code execution through alert templates.
Affected products
- librenms: before 26.8.0 — fixed in 26.8.0
How to fix
Upgrade to a fixed version: librenms 26.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-cvq8-gqfq-3mvg
- https://www.vulncheck.com/advisories/librenms-before-26.8.0-authentication-bypass-via-api-token-type-confusion
- https://github.com/librenms/librenms/security/advisories/GHSA-cvq8-gqfq-3mvg
Get alerted when CVE-2026-86426 or the next vulnerability affects your stack