What’s Vulnerable › Vulnerabilities
CVE-2026-86427: LibreNMS before 26.8.0 Argument Injection via graph_title
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-07 · updated 2026-09-18
- Weakness: CWE-77
Description
LibreNMS before 26.8.0 contains an argument injection vulnerability in the graph_title parameter that allows authenticated attackers to inject arbitrary rrdtool arguments by breaking out of double-quote escaping. Attackers can inject DEF and LINE arguments to read RRD files from unauthorized devices, or use newline injection to execute arbitrary rrdtool commands, bypassing per-device authorization checks.
Affected products
- librenms: before 26.8.0 — fixed in 26.8.0
How to fix
Upgrade to a fixed version: librenms 26.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-3hvv-wxpw-cx83
- https://www.vulncheck.com/advisories/librenms-before-26.8.0-argument-injection-via-graph-title
Get alerted when CVE-2026-86427 or the next vulnerability affects your stack