What’s Vulnerable › Vulnerabilities
CVE-2026-86428: commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-407
Description
commonmark versions from 1.5.0 before 2.10.0 contain a denial of service vulnerability in the AttributesExtension when processing distinctly-named attributes. Attackers can submit Markdown with numerous distinct attribute names to cause quadratic-time attribute merging and filtering, consuming disproportionate CPU resources and preventing legitimate requests from completing.
Affected products
- thephpleague commonmark: from 1.5.0 before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: thephpleague commonmark 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/thephpleague/commonmark/security/advisories/GHSA-8rr7-cvq3-gmfh
- https://www.vulncheck.com/advisories/commonmark-1.5.0-before-2.10.0-denial-of-service-via-attributes
Get alerted when CVE-2026-86428 or the next vulnerability affects your stack