What’s Vulnerable › Vulnerabilities
CVE-2026-86429: commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-407
Description
The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension. When either extension is explicitly registered on the Environment (they are not enabled by default and are excluded from the standard CommonMark and GitHub-Flavored Markdown converters), an unauthenticated attacker can submit small, specially crafted Markdown documents — such as text alternating with unpaired quotes, contiguous runs of block-level attribute blocks, or repeated class attributes — to trigger disproportionate CPU consumption and cause a denial of service. Fixed in 2.9.1.
Affected products
- thephpleague commonmark: from 1.5.0 before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: thephpleague commonmark 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/thephpleague/commonmark/security/advisories/GHSA-jjv6-8j6v-6j52
- https://www.vulncheck.com/advisories/commonmark-before-2.9.1-denial-of-service-via-smartpunct-and-attributes
Get alerted when CVE-2026-86429 or the next vulnerability affects your stack